Archive for 3月, 2011

このエントリーをはてなブックマークに追加
[`livedoor` not found]

PHPのセキュリティ対策例

・Script Insertion(スクリプト挿入)

————————————————————
$string = htmlspecialchars($post_data, ENT_QUOTES, ‘UTF-8’);
————————————————————

・$post_data はブラウザ等で入力されたデータが格納されている。

・htmlspecialcharsの第二引数は指定しない場合は”(ダブルクォート)でエスケープされる。
ダブルクォートでは変数が展開されるため、ENT_QUOTES ( ‘ ) シングルクォートを指定する。

・第三引数は文字コードなので、環境に応じ変更する。

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)
このエントリーをはてなブックマークに追加
[`livedoor` not found]

 今日はルータの設定。
ダイアルアップは久々にやると設定が曖昧になってました。
と、いうわけでメモメモ。

——————————
3/31 追記

NTT西日本によると、Bフレッツ・フレッツADSL・フレッツ光ネクストのMTUは1454だが、
フレッツ光プレミアムのMTUは1438になるとのこと。
なんで東西で違いが…

http://www.nttwest-fc.com/faq/faqdet.php?faq_code=1511

——————————

LAN払い出し型(IOS12.4以上)
——————————
service timestamps debug datetime localtime msec
service timestamps log datetime localtime msec
clock timezone JST 9
!
logging buffered 512000 debugging
!
hostname 1812J_LAN
!
ip subnet-zero
!
ip cef
!
interface FastEthernet0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet2
!
interface Vlan1
ip address xxx.xxx.xxx.xxx 255.255.255.240
ip tcp adjust-mss 1414
!
interface Dialer1
ip unnumbered Vlan1
encapsulation ppp
dialer pool 1
dialer-group 1
ip mtu 1454
ppp authentication chap callin
ppp chap hostname user@cisco.com
ppp chap password 0 password
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
end

————————————————————
端末払い出し型(IOS12.4以上)

——————————
service timestamps debug datetime localtime msec
service timestamps log datetime localtime msec
clock timezone JST 9
!
logging buffered 512000 debugging
!
hostname 1812J_Host
!
ip subnet-zero
!
ip cef
!
interface FastEthernet0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet2
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1414
!
interface Dialer1
ip address negotiated
ip mtu 1454
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname user@cisco.com
ppp chap password 0 password
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
!
end

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)